Introduction

- Please be sure to read and understand Precautions and Introductions in CX-One Setup Manual (W463-E1), CX-Programmer Operation Manual (W446-E1) and CX-Integrator Operation Manual (W464-E1) before using the product.

- This Guide describes the basic operation procedure of CX-Programmer. Refer to the Help or the Operation Manual of the PDF file for detailed descriptions.

- To read the PDF files, you need Adobe Reader, a free application distributed by Adobe Systems.

- The screen views used in this guide may be different from the actual view, and be subject to change without notice.

- The product names, service names, function names, and logos described in this guide are trademarks or registered trademarks of their respective companies.

- The symbols (R) and TM are not marked with trademarks and registered trademarks in this guide respectively.

- The product names of the other companies may be abbreviated in this guide.

- Microsoft product screen shots reprinted with permission from Microsoft Corporation.
# Table of Contents

Chapter 1 Overview and Installation of CX-One

1. What is CX-One? ........................................ 1-1
2. Features of CX-One .................................. 1-1
3. Integrated Simulation ................................. 1-2
4. CX-One Installation Procedure ...................... 1-4

Chapter 2 Example of PLC System Construction by CX-One

Workflow in This Chapter ................................. 2-1
1. Design
   1-1. Starting CX-Programmer .......................... 2-2
   1-2. Creating Unit Configuration ....................... 2-3
   1-3. Setting CPU Bus Units and Special I/O Units ... 2-5
   1-4. Checking I/O Assignment .......................... 2-9
   1-5. Programming ........................................ 2-10
   1-6. Offline Debug ....................................... 2-12
   1-7. Saving a Project .................................... 2-13
2. Online Debug on a Machine
   2-1. Reading a Project .................................. 2-14
   2-2. Online Connection to PLC ......................... 2-15
   2-3. Transferring to a Machine ......................... 2-16
   2-4. Program Debug ...................................... 2-21
3. Start-Up / Adjustment On-site
   3-1. Program Modification .............................. 2-23
   3-2. Unit Parameter Change .............................. 2-25

Chapter 3 Example of PLC Network System Construction by CX-One

Workflow in This Chapter ................................. 3-1
1. PLC Network Start-Up
   1-1. PLC Start-Up ....................................... 3-2
   1-2. DeviceNet Start-Up ................................ 3-6
   1-3. NT Link Start-Up .................................... 3-8
   1-4. Controller Link Start-Up ........................... 3-10
   1-5. CompoWay/F Start-Up ............................... 3-12
   1-6. Saving System Configuration ....................... 3-15
2. Adjustment On-site
   2-1. System Configuration Verification ................ 3-17
   2-2. Controller Link Diagnosis ........................ 3-19
   2-3. Checking CompoNet Network ....................... 3-20
3. Servo/Inverter Settings
   3-1. DeviceNet Connection ............................. 3-22
   3-2. RS232C Connection ................................. 3-23
Chapter 1
Overview and Installation of CX-One
1. What is CX-One?

CX-One is an FA Integrated Tool Package that integrates Support Software for OMRON's PLC and other Components.
To construct an FA System based mainly on PLC, traditionally it was necessary to purchase and install individual Support Software compatible with each Unit, start the software individually, and then connect to PLC and individual Components.
Installation of this FA Integrated Tool Package "CX-One" on a personal computer allows integrated operation from setup of OMRON's CPU Bus Units and Special I/O Units (SIOU) and Components to network start-up/monitoring and improving efficiency of PLC System start-up.

2. Features of CX-One

- CX-One allows integrated management of Support Software for OMRON's PLC/Components.
  - Installation on only one personal computer allows a user to handle Support Software for OMRON's products.
  - Only one licensing key is required to install all Support Software.
  - It allows integrated management of one save location for files created by Support Software.
- Support Software dedicated to CPU Bus Units and Special I/O Units can be started on the I/O Table.
  - The appropriate dedicated Support Software can be automatically started by specifying a registered Unit in the I/O Table (Unit configuration table attached to a PLC). In addition, setup information such as PLC model can be passed to the dedicated Support Software at start-up, allowing easier switching between Support Software.
- The following functions are available by the introduction of the ID information file (CPS) for OMRON Components.
  - Setup of CPU Bus Units and Special I/O Units without manual setting and address recognition.
    (Parameter and selection item names as well as available range of setup are automatically displayed)
  - CPU Bus Units and Special I/O Units setting on personal computer and data on actual PLC (CPU Unit) can be verified online, and unmatched item/readout data is displayed graphically.
  - Unit configuration is displayed on the I/O Table based on Unit model.
  - Device type on the network can be checked for its Unit model, allowing exact verification of network configuration.

What is CPS?

CPS (Component and network Profile Sheet) is definition information of CS/CJ series Unit/Components in CX-One. It is provided as a CPS file (XML format file). CX-One recognizes CS/CJ series Unit by information in this CPS file. CPU Bus Units and Special I/O Units setting is created based on this CPS file.
3. Integrated Simulation

Integrated Simulation Overview:
Integrated Simulation is a function of CX-One that simultaneously tests interoperability between the ladder program and PT (touch panel) and checks screen operation on the computer.

Earlier Versions:
Operation checks had to be performed separately on the ladder program and PT (touch panel) screens. In addition, the program had to be downloaded to the devices.

Using Integrated Simulation:
Provides an interoperability check between the ladder program and touch panel screens.

- Operation can be verified before actual devices such as the PLC and PT (touch panel) are installed and wired, so software quality can be improved in the design stage.

- Time can be saved by eliminating the tasks up to downloading the screen data from the computer to the PT.

- The operation of both the PLC and PT (touch panel) can be verified simultaneously in the computer, which greatly reduces the time required for debugging and equipment downtime during improvements.

Simulation of the PLC – PT (touch panel) system can be started easily, with one click of an icon.

Ladder program

CX-Programmer

Touch panel screen

CX-Designer

One click

Linked and simulation started.
Integrated Simulation Procedure

Use the following procedure to execute an integrated simulation of the ladder program and PT (touch panel) screen. For details, refer to the CX-Designer Operation Manual and CX-Programmer Operation Manual.

1. Create the screen data in the CX-Designer.

2. Click the Icon or select Tools – Integrated Simulation. The PLC-PT Integrated Simulation Dialog Box will be displayed.

3. Click the Browse Button and select the desired ladder program (CXP) file.

4. Click the Start Button. The PLC-PT Integrated Simulation will start automatically.

5. The test window will be displayed.

The Test Tool Window will list all of the communications addresses being used in the displayed screen. For example, when “Host SERIAL A” is connected to the CX-Simulator, the CX-Simulator value is reflected in the SERIAL A communications address. (The values can also be changed.)
4. CX-One Installation Procedure

Before installing the CX-One, you must:
- Terminate all Windows programs
- Uninstall previous versions of Support Software (such as CX-Programmer) if already installed.
- Installation takes about 15 to 45 minutes depending on your personal computer.
- To change/modify/delete CX-One after installation, refer to the PDF manual “CX-One Setup Manual”, Chapter 2 “Installation and Uninstallation”.

Installing CX-One

In case of the installing procedure by DVD-ROM:
Insert CX-One installation disk (DVD-ROM) into your personal computer’s DVD-ROM drive. [Choose Setup Language] dialog box is displayed. By default the OS language installed on your personal computer is automatically selected. Check if the language is appropriate, then click the [OK] button.

Click [OK]

The CX-One splash screen is displayed and CX-One installation starts.

Uninstall older version of tools such as PLC Tools (PLC System setting and I/O Table), CX-Server, and CX-Programmer if they have been installed.

Always click [OK]

Uninstalling CX-Programmer

Uninstalling CX-Server
CX-One setup wizard starts.

The [License Agreement] dialog box is displayed. Read the software license agreement carefully. If you agree with all items, select the [I accept the terms of the license agreement] radio button and click the [Next] button.

Select the radio button

The [User information] dialog box is displayed.

Enter [User], [Company], [License] (product serial number of CX-One)

Click [Next]

The [Regional Information] dialog box is displayed.

Select the [region] in which the software was purchased

Click [Next]
The [Installation Folder Selection] dialog box and [Setup Type] dialog box are displayed. Select an installation folder, then click [Next].

Select the radio button [Complete].

Click [Next].

The [Choose Destination Location of OMRON FB Library], [Select Program Folder], and [Ready to Install the Program] dialog boxes are displayed. Read the message and click [Next].

Click [Install].

CX-One installation is starts. During the installation, the [OMRON USB driver Installation Wizard], [WinPcap Setup Wizard], and [Direct Ethernet Connection: Network Card Selection] dialog boxes are displayed. Continue with the installation procedure according to the messages displayed by the Installation Wizard.

A dialog box (right) is displayed. Click the [Finish] button to finish the installation wizard.

Installation is complete. (When it is necessary to restart the personal computer, a restart confirmation dialog box appears.)

Click [Finish].

By selecting [Custom], you can individually select and install Support Software.
Online Registration

If the personal computer that the software has been installed on has an Internet connection, you can proceed to online user registration.

After installation has been completed the [Online Registration] dialog box is displayed.

If you click the [Register] button, your Web browser connects to “OMRON’s CX-One Web site”.\(^{1}\)\(^{2}\)

\(^{1}\): If you click the [Exit] button to cancel online registration, the [Online Registration] dialog box is displayed every time the CX-One Support Software is started.

\(^{2}\): If you do not have an Internet connection, or you do not want to register online, fill out and send the user registration card that comes with the product.
Chapter 2
Example of PLC System Construction by CX-One
Example of PLC System Construction by CX-One

Workflow in This Chapter

This chapter describes an example of PLC System construction from design, online debugging on the actual machine, and start-up/adjustment on-site as shown below.

CX-Programmer is used for ladder program creation and CPU Bus Units and Special I/O Units (SIOU) setting, while CX-Designer is used for indicator screen generation. Also, a program simulation Support Software CX-Simulator is used as a debugging example.

System Configuration

Below is an example of a System that has CJ1M CPU Unit with basic input/output Unit as well as analog input Unit and NCF Unit to perform the following functions:

- 4~20mA input from a sensor
- Configure a servo driver connected to the NFC Unit.
Starting CX-Programmer

From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Programmer] > [CX-Programmer] to start CX-Programmer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Programmer] > [CX-Programmer])

Click [OK] and determine CPU type.

Creating a New Project

Click this button to create a new CX-Programmer project.

Click and select PLC model.

Select a PLC model from the following to use Function Blocks:
- CP1H, CP1L, CP1L-E

Dedicated Support Software for each Unit can be started, succeeding communications settings from CX-Programmer. You will not have to set up communications using dedicated Support Software if you set up communications here.

Design
Creating Unit Configuration

Start the I/O Table/Unit setup function.

Right-click Empty Slot, select [Add Unit] and determine CPU type.

Then select [General Purpose Analog I/O] from Unit selection window.

When you select [Option] > [Consumption(mA)] from the menu, you can check the width and current consumption after PLC Unit configuration. (Width indication is available only for SYSMAC CJ Series, CP1H Series.)

Double-click [I/O Table and Unit Setup].

Right-click Empty Slot, select [Add Unit] and determine CPU type.
Then select [General Purpose Analog I/O] from Unit selection window.
Select Unit Type.

Select Unit and Number.

Click OK
Double-click the analog Unit

The Analog Unit is registered to the I/O Table as shown below.
Set up the next analog Unit’s parameter.

The Analog Unit Setup Screen is displayed.

CPU Bus Units and Special I/O Units Setting Function
Traditionally, initial CPU Bus Unit and Special I/O Unit settings were made by referring to documentation to calculate DM address from the Unit number and entering a hexadecimal number. Now you can set it using the pull-down menu in the CX-Programmer’s I/O Table.
Easy setup/transfer/verification operations are available from the integrated parameter settings screen as shown below, without recognizing addresses (this function uses CPS function of CX-One previously described).

Setting CPU Bus Units and Special I/O Units
For example, specify input number designation and range.

Select [Enable] for input No.1 usage designation.
Select [1~5V/4~20mA] for input No.1 range setting.
Click the [OK] button.
NCF Unit and Servo Driver Connected to the NCF Unit Setup

As with Analog Unit registration, register the NCF Unit (CJ1W-NCF71). The NCF Unit resides within a position control Unit. Next, start CX-Motion-NCF using [Start with Settings Inherited].

When opening a stored project file after starting the dedicated tool, select [Start Only]. If [Start with Setting Inherited] is selected, a new project is created.

Right-click NCF Unit

Point [Start Special Application]

Click [Start with Settings Inherited]

Double-click NCF Unit

Click

Select OMRON W series (with communications function).

Select R88D-WN01L-ML2.

Displayed with NCF Unit registered.

Register a servo driver.

Double-click NCF Unit.

Click

Press [F1] to display help.
Double-click NCF Unit

Edit NCF Unit parameters.

Set output relay area to CIO100 and input relay area to CIO500.

Select [Communications Setting] -

Click Auto Communications Setting

Set axis parameters for axis 01.

Click OK

Double-click the servo driver

Edit servo parameters.

Set servo parameters for axis 01 as shown below.
Pn50A(input signal selection 1): 2881
Pn50B(input signal selection 2): 8883
Pn511(input signal selection 5): 6541

Click OK

Save the project

Refer to Page 2-13 “Saving Project” for details.
Using the MCH Unit

When using the MCH Unit (CJ1W-MCH71) instead of the NCF Unit, use the following settings.

As with Analog Unit, register the MC Unit to the I/O table.
The MCH resides within the Motion Controller.
Then start CX-Motion-MCH using [Start with Settings Inherited].

When opening a stored project file after starting the dedicated tool, select [Start Only].
If [Start with Setting Inherited] is selected, a new project is created.
Register basic I/O Unit

As with Analog Unit registration, register the IN and OUT Units.

In this example, CJ1W-ID211 and CJ1W-OD211 are selected as IN and OUT Units respectively.

By registering Units to the I/O Table, you can check I/O assignment status.

In addition, you can check addresses assigned to actual I/O with a print out.

This I/O assignment information can also be checked by IQ indication (IN:I, OUT:Q) during ladder programming.
This section describes programming with Library (OMRON Standard Libraries) that allows easier connection to OMRON’s Components. OMRON Standard Libraries is a group of Components provided by OMRON, which can be categorized into two types; FB Components (OMRON FB Library) to be used for a ladder program and SAP Components (Smart Active Parts Library) to be used for an indicator.

● NCF Unit Programming with OMRON FB Library

Servo motor (axis 1) connected to Unit number 0 NCF is moved to position 2000 (command Unit) with speed of 2000 (command Unit/s) by relative move command.

OMRON FB Library is a collection of Components that OMRON provides as a Function Block to use functions of OMRON’s Units for PLC and FA Components much easier on a PLC program. * For details, see FunctionBlock StructuredText Introduction Guide, Chapter 1.
How to use Smart Active Parts

This section describes how to use Smart Active Parts. In this example, NCF Smart Active Parts "Adjust Operation" is used.

From [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.□] to start CX-Designer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.□].) Select [NS8-TV0]-V2 and [System Version 6.0] or later.

1. Double-click SAP - SmartActiveParts_E - Motion - NCF - OutClO_InClO folder
2. Select _NCF001_xx_Adjust Operation (Check the Title)
3. Drag & drop it on the screen.
4. The selected Smart Active Parts are displayed on the screen.

1. Select [Library] from the [Tools] menu
2-11
This section describes how to debug a program using CX-Simulator, a ladder simulation tool, without the PLC. Additionally, Switch Box Utility is used as a virtual input tool.

Starting Switch Box Utility
Select [Tools] > [SwitchBox Utility]

Run PLC
Switch Box Utility
It is useful not only for virtual input by simulator but also for debugging while checking the PLC’s wiring or setting the DM and other initial values.
Saving a Project

Unit setting, Unit parameter setting, and programs using the CX-Programmer can be saved all at once.

Save it with a name. In this example save as “Sample1”.

Created data can be saved for CX-Designer and CX-Motion-NCF/MCH.
Save CX-Motion-NCF as “Sample2.mnf” (CX-Motion-MCH as “Sample5.mnh”), and CX-Designer as “Sample3.ipp”.

If you run a dedicated Support Software such as CX-Motion-NCF or CX-Designer when CX-Programmer is started, the same default folder location as that of CX-Programmer is used for reading and saving files. It allows easier CX-One Support Software file management.
This section describes connection to the machine, transfer of programs, creating Unit settings offline, and how to debug.

**Reading a Project**

Use CX-Programmer to read the project "Sample1" saved in the previous section.

Ladder program "Sample1" is retrieved.

In I/O Table Unit setting function, the Unit parameter setting configured in the previous section is also retrieved.

From [File] > [Open], select the file name "Sample1"

or

Click

Double-click the I/O Table Unit setting
Online Connection to PLC

Verify that PLC model and communications setting created offline and the actual PLC are correct.

Double-click PLC

Check PLC model.

Check communications setting.

Click

(Online connection button)

Confirm that automatic communication speed recognition is checked.

If a connection cannot be established with the PLC, you can use the automatic online connection function. Save your current project data before using this function because it clears project data being edited. When USB conversion cable (CS1W-CIF31) is used for connection, specify the COM port number of the USB port used.

(Automatic online connection button)
Transfer programs and Unit setting parameters created by offline project to the PLC. In this example, data is sent at the same time to various Units using the batch transfer function.

[Data to be sent]
- CPU Unit: Ladder program and PLC System setting data, I/O Table data
- CPU Bus Units and Special I/O Units:
  - AD Unit: Range setting of inputs (1~5V / 4~20mA mode)

Program and configuration data are transferred at the same time to CPU Bus Units and Special I/O Units.
Then data is sent at the same time to NCF Unit and the servo driver connected to NCF Unit.

[Data to be sent]
NCF Unit: Common parameters, axis parameters
Servo Driver: Servo parameters

From CX-Programmer, display the I/O Table, then start CX-Motion-NCF by [Start Only].

Right-click NCF Unit
Point [Start Special Application]
Click [Start Only]

Open a saved project and transfer all NCF Unit and servo driver parameters.

To prevent a servo driver operation using a ladder program, you must set the PLC to PROGRAM mode.

Click
Select “Sample2.mnf”
Click
Double-click NCF Unit

If it does not go online, click and check the communications setting between the personal computer and PLC.
Next, perform jog operation. Carefully read the displayed cautions, then perform the operation.
To perform jog operation, it is required to establish a connection, servo lock, and jog setting.

When parameter transfer is completed, confirm that communications is performed normally and has not resulted in an error.
Monitor the NCF Unit. Confirm consistent scan list (axis configuration) and communications status and that no axis or common Unit error has resulted.

The Unit restart confirmation screen will be displayed during data transfer. Click the [OK] button after confirming safety. Also, in the case of communication was not established between the NCF Unit and the servo driver, confirm the axis number and restore power to the NCF Unit and servo driver.

Next, perform jog operation. Carefully read the displayed cautions, then perform the operation.
To perform jog operation, it is required to establish a connection, servo lock, and jog setting.
When using the MCH Unit, transfer data from the CX-Motion-MCH to the MCH Unit and servo driver connected to the MCH Unit.

[Data to be transferred]
- MCH Unit: parameter, position data, program, CAM data.
- Servo driver: servo parameter

Display the I/O table from CX-Programmer and start CX-Motion-MCH with [Start Only]. (Refer to NCF Unit for starting from the I/O table.)

Open the saved project and transfer Unit parameter, position data, program, CAM data, and servo driver parameters to the MCH Unit.

To prevent a servo driver operation using a ladder program, you must set the PLC to PROGRAM mode.

If it does not go online, double-click PLC in the project tree and check the communication settings between the personal computer and PLC.

The Unit restart confirmation screen will be displayed during data transfer. Click the [OK] button after confirming safety. Also, in the case of communication was not established between the MCH Unit and the servo driver, confirm the axis number and restore power to the MCH Unit and servo driver.
Transferring NS screen data

This section describes how to transfer screen data to the NS through PLC without changing cables.

From [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.□] to start CX-Designer. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Designer] > [CX-Designer Ver.□].) Open a project saved in the previous section.

Select [Transfer]-[Transfer[To PT…]] from the [PT] menu.

Click [Setting] to activate the “PC → PLC → NS” route setting.

Check “Pass thru PLC” to activate the “PC → PLC → NS” route setting.

Check “Pass thru PLC” in the Comm. Method window.

Setup “Data transfer to the NS through PLC”.

Select Serial(Toolbus)

Select NT Link

Transfer screen data

Click OK to start transfer

*Communication between the NS and the PLC must be established before transferring screen data through PLC without changing cables.

If “Connecting…” is displayed at the right bottom of the screen, use Auto Connection (See Chapter 3 1-3 “Setup NT Link”) to connect the NS and the PLC before starting the following procedure.

If the communication between the NS and the PLC has already been established, you do not need to perform the operation described above.

Select PC – PLC – NS.

Set the serial port COM No. for PC → PLC connection. Then, press OK.

Enter NS Unit No. Then, press OK.

Screen data transfer is complete at 100%.
Program Debug

Transfer programs and Unit setting parameters created by an offline project to the PLC. In this example, data is sent at the same time to various Units using the batch transfer function.

Monitoring

Monitor ON/OFF status of contacts and coils.

Click [Yes]. . . ON/OFF of monitoring

Frame color changes to a specified color during Function Block execution.

Current parameter value is displayed.
Monitoring - Changing the Current Parameter Value

Change the current value of contact or channel through conductive monitoring.

Move the cursor to D100 of input parameters

Right-click, then select [Set/Reset (S)] > [Value (V)] from the pull-down menu

or

Double-click

Or

Enter [ENT]

Change current value of the input parameter.

Ensure to add "#" (hexadecimal/BCD) or "&" (decimal) to the left of the value.
Select [Program] > [Online Edit] > [Start]

Enter the contact number you want to modify (W20.01 in a circuit example).

Select [Program] > [Online Edit] > [Transfer Change]

Shortcut [Ctrl]+[E]

Enter the contact number you want to modify (W20.01 in a circuit example).

Select [Program] > [Online Edit] > [Transfer Change]

Shortcut [Ctrl]+[Shift]+[E]

Move the cursor on the circuit you want to modify

You can use drag-and-drop to specify more than one circuit at the same time

Move the cursor on the contact you want to modify and double-click

Shortcut [Ctrl]+[E]

Double-click
Verifying Program

After modification on-site, you can verify it with the designed program and display the differences graphically. This allows for easier checking of the parts modified on-site.

1. Read the designed program. In this example, read “Sample1”. Then connect online.

2. Select verification.

3. Display the verification result.

You can check ladder contact address differences.

In addition, you can check add, delete, and move contacts, coils, and apply instructions.

You can check FB parameter differences.
Unit Parameter Change and Verification

After modification on-site, you can verify it with the designed Unit parameter and display the differences graphically. This allows for easier checking of the parts modified on-site.

1. Read the designed program. In this example, read “Sample1”. Then connect online. (If you have already read it in the previous section's operation, this is not required)
   Open the I/O Table/Unit setting, then double-click the AD Unit.

2. Click the [Compare] button. Now you can see the difference between the designed Unit parameters and the configured parameters in the machine.

3. Unmatched detail differences can also be checked.

You have now completed Chapter 2: Example of PLC System Construction by CX-One. The next chapter describes PLC network construction flow.
Chapter 3
Example of PLC Network System Construction by CX-One
Example of PLC Network System Construction by CX-One

Workflow in This Chapter

This chapter describes an example of PLC network System construction from start-up to reassembly and on-site adjustment as shown below.

This chapter mainly describes how to start up the System using CX-Integrator, an integrated start-up Support Software for various PLC networks.

Start-Up

- Describes details from assembly and wiring of PLC System to program download for a trial run.
- Target of Start-Up
  Aims at removing the cause of errors from a PLC and to turn off all of red LEDs that indicate errors for any component of the PLC System.
- Saving the entire system configuration after completing start-up is recommended. You can utilize it for system adjustment on-site after delivery to reduce the adjustment period.

Adj. On-site

- Describes details from disassembly of a system for which the trial run, delivery, and reassembly on-site as well as operation check have been completed.
- Target of Adjustment On-site
  1) Confirm that no error will occur in its electrical system in the same system configuration as that before delivery.
  2) Confirm that no discrepancy will be found in Controller Link network settings by connecting to a network on-site.
  3) Though CompoNet network is characterized by tool-less easy start-up, using the tool can shorten the time required to check the wiring.

System Configuration

Note) The Local Network Table is required in order to attach more than one network communications Units.
1. From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Integrator] > [CX-Integrator] to start CX-Integrator. (Or select [All Programs] > [OMRON] > [CX-One] > [CX-Integrator] > [CX-Integrator])

CX-Integrator starts and automatically connects online.

(Important)
This operation is used for online connection to any PLC hereinafter. Unless described otherwise, use this operation to connect online.

Select a serial port. When USB conversion cable (CS1W-CIF31) is used for connection, specify the COM port number of the USB port used.

Select a serial port, then click [Connect]

All communications Units and ports of a connected PLC are automatically displayed in the online connection information window.
(1) Remove the cause of the PLC error, then make it available to run.

(2) Check the PLC error.
Examples of IO settings error and CPU Bus Units and Special I/O Units number overlap error are shown below.

(3) Solve the cause of error.
You must solve the problem through the following procedure:
- Set the PLC to PROGRAM mode (in which you can change settings).
- Change the rotary switch of the CPU Bus Units and Special I/O Units (make sure that it does not overlap).
- Create the I/O Table.

- Set the PLC to PROGRAM mode.
From step (1) above, select [Mode Setting] then [Program] mode, and click the [Set] button.

Click [Yes].
- To change the Unit number, change the rotary switch of CPU Bus Units and Special I/O Units and restart power.

- Check if any error occurs in the PLC (CPU Bus Units and Special I/O Units number overlap error should be solved).

- Create the I/O Table.

- Check if any error occurs in the PLC (all errors should be solved).
Confirming the Routing Table is not Configured

1. Check that Routing Table is not configured.
   - Check Routing Table presence. If the Routing Table is not configured, create one.

2. Configure the Routing Table.
   - Move the cursor on the PLC and right-click
   - Select [Start Routing Table]

3. Edit the Routing Table and transfer to [PLC].
   - Right-click and select local network (Unit) [Insert CPU SIOU] or local network (port) [Insert PORT]
   - Enter its local network number, then click [OK]

4. Check if the error is solved.
   - Re-connect to the PLC
   - All errors should be solved and no error messages should be displayed.
   - The network number is displayed on the communications Unit.
DeviceNet Start-Up

Remove DeviceNet communications errors and establish communications.
⇒ Check DeviceNet Unit’s 7SEG indication and ON state of MS/NS LED.
⇒ Check Slave Unit configuration through CX-Integrator.
Create a scan list of DeviceNet and determine the memory map.

(1) Connect to PLC online, then connect to DeviceNet through the online connection information window.

(2) Next, upload the network configuration information of DeviceNet.

In this example, although one Master Unit (node number #01) and two Slave Units (node number #02, #03) are actually connected, assume in this start-up example that one Slave Unit (#03) is not connected due to disconnection.

(3) After transfer is confirmed, connected devices on the current DeviceNet network are displayed as shown below.

Check if a Slave device on the remote I/O communications actually wired is recognized. Master Unit (#01) and Slave Unit (#02) are recognized, while another Slave Unit (#03) is not recognized.
Right-click on the Master Unit icon and select [Monitor] to display the device monitor screen. Select [Status] tab.

(4) Check the error on the device monitor screen.
You can check the Slave status on the device monitor screen as well.

(5) Wire Slave Unit (#03) correctly.

(6) Re-upload the network configuration information of DeviceNet.

(7) Configure DeviceNet remote I/O communications (free assignment) and register the Slave to the Master.

(8) Configure assignment of Slaves to areas of a CPU Unit. If necessary, configure the Slave parameters as well.

(9) Start remote I/O communication.
** Remove NT Link communication errors and establish communications.

- Release NS Connecting . . . message.
- Check NS configuration through CX-Integrator.

1. Connect to PLC online, then connect to a CPU Unit through the online connection information window.

   ![Diagram showing connection process]

2. Select in the order from upper link port to NT link.

   ![Diagram showing selection process]

3. Next, select [NT Link Tool] > [NTLink Auto Online Setting] from the CPU Unit.

   ![Diagram showing selection process]

Automatic NT Link connection function is used to automatically connect NS series PT and PLC via serial connection (NT Link). Connection is automatically performed by overwriting the PLC serial communication port settings by adjusting to NS series PT settings.

---

3-8
(5) Screen message Connecting . . . is now cleared.

(6) Next, upload the network configuration information of NT Link.

(7) After the transfer is confirmed, connected devices on the current NT Link network are displayed as shown below.
Controller Link Start-Up

Remove Controller Link communications errors and establish communications.
⇒ ON state of Controller Link Master Unit's INS LED
⇒ Check Controller Link configuration through CX-Integrator.

(1) Connect to PLC online, then connect to Controller Link Unit through the online connection information window.

- Right-click a Controller Link Unit in the online connection information window, then select [Connect]

- Select [Transfer [Network to PC]]

- Click [Transfer]

(2) Next, upload the Controller Link network configuration information.

- Select [Transfer Network [#001] to PC]

- Click [Transfer]
In this example, although three PLCs are actually connected through the Controller Link, in this start-up example explanation assume that only two PLCs are displayed. (One PLC did not join the communications due to incorrect Routing Table settings)

(3) After the transfer is confirmed, connected devices on the current Controller Link network are displayed as shown below.

(4) Check the Routing Table and configure it correctly. See “Confirming the Routing Table is not Configured” for configuration details.

(5) Re-upload the Controller Link network configuration information.

(6) Send the network configuration from the network to the personal computer.
This example explains the start-up of a serial communications Unit with two temperature controllers (E5CN) connected via CompoWay/F.

- Two temperature controllers (E5CN) are connected to serial communications Unit (CS1W-SCU41-V1) port no. 1 via RS485. Communication Unit numbers are #001 and #002.
- Communication settings of the serial communications Unit and the two temperature controllers are unmatched.
- Communication settings between the two temperature controllers are unmatched as well.

**CompoWay/F Start-Up**

Remove CompoWay/F communications errors and establish communications.

⇒ Check CompoWay/F configuration through CX-Integrator.
⇒ Configure serial communications Unit parameters.
⇒ Configure temperature controller communications.

(1) Connect to PLC online, then connect to a CPU Unit through the online connection information window.

- Right-click an SCU port in the online connection information window, then select [Connect]
- Select SCU port (140)
- Select CompoWay/F

(2) Upload the CompoWay/F network configuration information.

- Right-click an SCU port in the online connection information window, then select [Transfer Network to PC]
- Click [Yes] in the message dialog box
- Select [Selection], enter 1 for minimum and 2 for maximum values, then click the [OK] button
(3) Adjust the serial communications board parameters settings to those of the CompoWay/F.

Right-click a Target PLC in the online connection information window, then select [Mode Setting].
(a) Select [Program] for operation mode
(b) Click [Set]
(c) Click [Close] after changing

Place the cursor on CJ1M-CPU in the [Network Structure] window and double-click

From the [Display Parameter] pull-down menu, select [Port1: Serial Gateway Settings]
Click [OK] in the [Edit Parameters] dialog box and close the dialog box

Perform the step (2) in the previous page
Click [OK] button in a dialog box indicating completion of transmission

Click [OK]
This dialog box is displayed because communication is not established between the serial communications Unit and temperature controllers.

(4) Re-upload the network configuration information of CompoWay/F. Perform the step (2) from the previous page.

Only the Units for which connection is established are displayed in the [Network Structure] window, as shown on the next page.
The [Network Structure] window shows only the Units for which connection is established, and Units with incorrect communications setting are not displayed.

Check the temperature controller that is not displayed properly and configure it correctly.

(5) Check the settings of the temperature controller that is not displayed in the [Network Structure] window (baud rate, data length, stop bit, parity, Unit number), configure it correctly, then re-upload (Perform step (2) from two pages ago). The [Network Structure] window is updated.

Now the correctly configured Unit is displayed and you can confirm that communications settings are correct.

(6) Move the cursor on E5CN of communications Unit number #002, then select [Start Special Application] > [Start with Setting Inherited].

Right-click on the communications Unit number #002 icon in the [Network Structure] window, then select [Start Special Application] > [Start with Setting Inherited].

(6) Dedicated Support Software CX-Thermo is started with the same model and setting as that of the temperature controller. After parameter settings are finished, download the settings to the E5CN of communications Unit number #002.
Save the system configuration for inspection after delivery.

(1) Connect online to a PLC on a network.
   The online connection information window is displayed.

(2) Send the network Structure of DeviceNet to the personal computer.
   Connect to DeviceNet from the online connection information window. After connection
   is established, send the network Structure of DeviceNet to the personal computer.

(3) Send the network configuration of NT Link to the personal computer.
   Select the connection menu on the CPU port, then select upper link port and NT Link.
   Next, select the transmission menu on the CPU port.

(4) Send the Controller Link network configuration to the personal computer.
   Connect to the Controller Link network. After connection is established, send the network
   configuration to the personal computer.
(5) Connect to a PLC on the Controller Link network.
Select a remote PLC on the Controller Link network configuration screen (a PLC without a square symbol) to switch the connection destination to the PLC.
Destination PLC communication device configuration is displayed in the online connection information window.

(6) Send the DeviceNet network configuration on the remote PLC.
Connect to DeviceNet from the online connection information window and send the network configuration to the personal computer.

(7) Send the DeviceNet network configuration on another remote PLC.
Repeat the steps from (6) and (7). After transmission, all the networks sent to the workspace are displayed.

(8) Save all the configurations.
Confirm that the System has the same wiring and settings as before disassembly.

\[ \Rightarrow \text{CX-Integrator verification is complete.} \]

1. Connect online to a PLC on a network.
   The online connection information window is displayed.

   ![Online connection information window](image)
   All communications Units and ports of a connected PLC are automatically displayed in the online connection information window.

2. Verify the DeviceNet network configuration.
   Connect to a target DeviceNet from the workspace and verify the network Structure.

   ![DeviceNet network configuration](image)
   Select [Connect]
   Select [Compare]

3. Any error found in the configuration verification will be displayed in the verification result dialog box.

   ![Verification result dialog box](image)
   If you find a Slave that is not on the network, you may have incorrect wiring in the network.

4. After solving the error, verify the configuration again.

   ![Verification result dialog box](image)
   A message is displayed indicating verification matching and now it can be confirmed that the configuration is the same as that before disassembly.

Click [Close]
Click [OK]
<table>
<thead>
<tr>
<th><strong>PLC Network Start-Up</strong></th>
<th><strong>DeviceNet Start-Up</strong></th>
<th><strong>NT Link Start-Up</strong></th>
<th><strong>Controller Link Start-Up</strong></th>
<th><strong>CompoWay Start-Up</strong></th>
<th><strong>Saving System Config.</strong></th>
<th><strong>Equipment Disass'y/Reass'y</strong></th>
<th><strong>System Config. Verification</strong></th>
<th><strong>Controller Link Diagnosis</strong></th>
</tr>
</thead>
</table>

## System Configuration Verification (2)

(5) Verify the NT Link network.
Connect to the NT Link from the workspace and verify the network configuration. Confirm that the same verification matching message is displayed as in step (4).

Select [Connect]
Select [Compare]

(6) Verify the Controller Link network.
Connect to DeviceNet from the online connection information window and verify the network Structure. Confirm that the same verification matching message is displayed as in step (4).

Select [Connect]
Select [Compare]

(7) Connect to a PLC on the Controller Link network.
Connect to a remote PLC using the same procedure as the step (5) for saving a System configuration. Use steps from (2) to (4) to verify the DeviceNet network.

Select [Change connection to this PLC]
Select [Connect]

(8) Verify the DeviceNet configuration on another remote PLC.
Use the same procedure as step (2) for Network “N4” to verify the network Structure.
Controller Link Diagnosis

Confirm that the Controller Link connection is correct with an upper level System.
⇒ Diagnosis result check OK

(1) Connect to PLC online, then connect to Controller Link Unit through the online connection information window.

Right-click a Controller Link Unit under Target PLC in the online connection information window, then select [Connect].

(2) Next, select the Controller Link network tool.

Next, select the Controller Link network tool.
Checking CompoNet Network

Remove CompoNet communications errors and establish communications. Check the Slave status monitor from Master Unit.

(1) Connect to PLC online, then connect to a CompoNet through the online connection information window.

(2) Transfer the CompoNet network configuration to the personal computer.

(3) Select [Master only (including parameters)], then click [Transfer] button.

The Master Unit is displayed in the network configuration window.
Right-click on the Master Unit icon and select [Monitor] to display the device monitor screen. Select [Status] tab.

(4) Monitor a component.

The monitor window is displayed.

(5) Click [Slave Status] tab to check the status of Slave Units.

An error is detected in the Slave Units indicated in red.

(6) Repeat the steps (2) and (3) to confirm that the CompoNet network is functioning properly.

If any unit is missing or communication errors are detected, check the wiring and DIP switch settings of the applicable units to solve the problems.
Starting CX-Drive via DeviceNet

Setup Drives on DeviceNet and start CX-Drive on CX-Integrator window. An example of 3G3MV-PDRT2 is shown below.

When opening a stored data file after starting the dedicated tool, select [Start Only]. If [Start with Setting Inherited] is selected, new data is created.

CX-Drive starts and Inverter property settings are shown

Select Settings to set detailed Inverter specifications.

Save data

If more than one drive setting data is edited, drive data is saved by drive type and a total overview is saved in a work file.
From the [Start] menu, select [Programs] > [OMRON] > [CX-One] > [CX-Drive] > [CX-Drive] to start CX-Drive when you connect Servo or Inverter with serial connection to your computer.

Select [File] > [New] to create new data if the drive specifications are known. If the drive is already connected, select [Driver] > [Autodetect] to detect the model and specification of this connected drive.

To execute Autodetect, select [Settings] and define the search conditions.

Select [Driver] > [Autodetect] to detect the connected drive specification.

Click and save the data.